تنظیمات SMTP و ارسال ایمیل

Started By mortaza2006, Aug 30 2011 03:32 PM

71 پاسخ برای این موضوع
mortaza2006

    عضو فعال

  • عضو انجمن
  • ستارهستارهستاره
  • 11 محبوبیت
  • 119 ارسال

ارسالی 30 August 2011 - 03:32 PM

گاهی اوقات ممکنه از سرور ایمیل ارسال نشه مثل سایت من و مجبور باشی از stmp برای اینکار استفاده کنی یعنی سرور شما که قابلیت ارسال ایمیل با تابع PHP mail رو پشتیبانی نمیکند اما برای اینکار باید تنظیماتی رو انجام بدید که به شرح زیر هست.

ابتدا به مدیریت فروشگاه خود بروید بعد به تب تنظیمات بعد از زیر تب اون ايميل رو بزنید با عکس زیر روبرو می شید که شامل تنظیمات stmp هست
روی دکمه رادیویی پارامترهای SMTP من را مقدار دهی کن. فقط برای کاربران حرفه ای
کلیک کنید بعد زیرش چندتا فیلد برای تنظیمات stmp داده شده که با استفاده از اطلاعات زیر کاملش کنید

فایل پیوستی  untitled.JPG   19.43K   421 تعداد دریافت ها

تنظیمات SMTP برای گوگل (Google)

سرویس دهنده SMTP: این آدرس را وارد کنید smtp.gmail.com
رمزگذاری و درگاه: پورت گوگل برای ssl برابر است با 465 و پورت گوگل برای TLS برابر است با 587

تنظیمات SMTP برای یاهو (Yahoo)


سرویس دهنده SMTP: این آدرس را وارد کنید smtp.mail.yahoo.com
رمزگذاری و درگاه: پورت SSL یاهو برابر است با 465 از پورت TLS برای یاهو استفاده نکنید

تنظیمات SMTP برای لایو و هات میل (Hotmail و Live)


سرویس دهنده SMTP:
این آدرس را وارد کنید smtp.live.com

رمزگذاری و درگاه:
پورت SSL لایو و هاتمیل برابر است با 25 پورت TLS لایو و هاتمیل برابر است با 587


نکته های استفاده از smtp

1– بهتر است از SSL یعنی مورد اول استفاده کنید
2 – توجه داشته باشید که نوع پورت را با کد آن متناسب انتخاب کنید

قسمت کاربر stmp و کلمه عبور stmp :

در وارد کردن کاربرstmp توجه داشته باشید که نباید آدرس سایت ایمیل را بیاورید و فقط نام اکانتی را که وارد کردید رو بنویسید به همراه رمزش.

مثلا برای ایمیل presta-shop@gmail.com فقط presta-shop و پسورد را وارد کنید.


بعد از انجام این تغییرات ذخیره کنید و از قسمت بررسی تنظیمات ایمیل شما

یک ایمیل آزمایشی ارسال کنید ببنید درست کار می کند.


موفق باشید.:heart:
hidden

    عضو قدیمی

  • عضو انجمن
  • ستارهستارهستارهستارهستاره
  • 16 محبوبیت
  • 1060 ارسال

ارسالی 30 August 2011 - 04:07 PM

من سرورم امکان ارسال ایمیل رو داره و دستی وارد کردم اطلاعاتی که از سرور هاست گرفته بودم بازم ارسال نمیکنه
admin

    مدیر و موسس انجمن

  • مدیر کل
  • 1006 محبوبیت
  • 5344 ارسال

ارسالی 30 August 2011 - 04:08 PM

فوق العاده. عالیه. ممنون مرتضی جان.

موفق باشید
admin

    مدیر و موسس انجمن

  • مدیر کل
  • 1006 محبوبیت
  • 5344 ارسال

ارسالی 30 August 2011 - 04:11 PM

اصلا متوجه نشدم......
برای اینکه جیمیل رو انتخاب کنیم باید چیکار کنیم ؟؟؟؟ لطفا واضح توضیح بدید ممنون میشم


هیدن جان اطلاعات پنل ادمینت رو برای من پ.خ کن تا برات تنظیم کنم.

موفق باشید
mortaza2006

    عضو فعال

  • عضو انجمن
  • ستارهستارهستاره
  • 11 محبوبیت
  • 119 ارسال

ارسالی 30 August 2011 - 04:14 PM

بابا از این هم ساده تر !!!:huh:
ابتدا به مدیریت فروشگاه خود بروید بعد به تب تنظیمات بعد از زیر تب اون ايميل رو بزنید با عکس زیر روبرو می شید که شامل تنظیمات stmp هست
روی دکمه رادیویی پارامترهای SMTP من را مقدار دهی کن. فقط برای کاربران حرفه ای

هر کدوم رو در جاهای خودش بنویس :
سرویس دهنده SMTP

smtp.gmail.com
رمزگذاری رو بذار روی ssl
در درگاه :465

قسمت کاربر stmp و کلمه عبور stmp هم اطلاعات اکانت خود رو بنویسید.
hidden

    عضو قدیمی

  • عضو انجمن
  • ستارهستارهستارهستارهستاره
  • 16 محبوبیت
  • 1060 ارسال

ارسالی 30 August 2011 - 04:37 PM

والا نوشتم همینا رو دیگه نمیدونم چیکار کنم.....  

اصلا متوجه نشدم......
برای اینکه جیمیل رو انتخاب کنیم باید چیکار کنیم ؟؟؟؟ لطفا واضح توضیح بدید ممنون میشم


هیدن جان اطلاعات پنل ادمینت رو برای من پ.خ کن تا برات تنظیم کنم.

موفق باشید

عزیز پیغام خصوصی کردم لطفا برام نصب کن اطلاعات همه چی رو دادم ... منتظر پیام شما هستم:(
sufi

    عضو جدید

  • عضو انجمن
  • 0 محبوبیت
  • 6 ارسال

ارسالی 15 October 2011 - 11:41 PM

دوستان من وقتی رو یه هاست رایگان بودم رو همون php تنظیم بود و مشکلی نداشت
اما وقتی اومدم رو یه هاست دیگه مجبور شدم smtp رو تنظیم کنم.الان مشکلی که برخوردم اینه که اگه کسی خرید کنه واسم میل میشه اما وقتی پیام می زاره (مثلا شماره سفارش) میل نمیشه(البته فقط واسه من. واسه خودش میل میشه!) عجیب تر اینکه تنها اگه تو قسمت پیام به جای ایمیل مشتری ایمیل خودم رو بزارم واسم میل میشه یعنی از خودم به خودم ایمیل میاد.
این در حالیه که تنظیمات رو نسبت به قبل تغییر ندادم
ممنون میشم راهنمایی بفرمایید
دانوش

    مدیر پروژه

  • مدیر کل
  • 572 محبوبیت
  • 5188 ارسال

ارسالی 16 October 2011 - 12:00 PM

شما به بخش کارمندان برید و ایمیل مدیر رو چک کنید تا صحیح وادرد شده باشه.
به بخش تنظیمات - ایمیل برید و
ارسال نامه الکترونیکی به
را به «مدیر» تغییر بدید.
در صورت نیاز هم میتونید یک کارمند به عنوان سرویس مشتری تعریف کنید
amin233

    عضو انجمن

  • عضو انجمن
  • ستارهستاره
  • 0 محبوبیت
  • 38 ارسال

ارسالی 05 January 2012 - 08:18 PM

با سلام
من قبلا خيلي تلاش كردم ولي نشدكه نشد
الان هم دوباره امتحان كردم نشد
فكر كنم مربوط به هاستي بشه كه سايت روشه
لطفا دوستان نظرشون رو بدهند
چون خيلي كاربردي است
ممنون
p3ym4n

    عضو انجمن

  • عضو انجمن
  • ستارهستاره
  • 4 محبوبیت
  • 96 ارسال

ارسالی 01 February 2012 - 02:11 PM

در مورد این قسمت باید بگم که تنظیمات گوگل کار نمی کنه و این هم فک کنم بخاطر خود گوگل هست نه تنها اینجا بلکه تو دیگری فروم های خارجی پرستا سر این موضوع بحث بوده و به نتیجه ای نرسیدن ، این تنظیماتی که تو پست اول اومده توسط خود گوگل پخش شده و درست هم هست ولی کار نمی کنه!
البته این ایراد برای من یکی بهتر هم شد ، طی این جند ماه کار با پرستا یکسری تجربه بدست آوردم که به نظرم جالب باشه برای دوستان ،
خوب مورد اول اینکه شما اگه هاستت تنظیمات smtp رو ارائه می کنه بهتره که از این گزینه استفاده بکنید ، چون استفاده از تابع mail پی اچ پی امکان مواجه شدن با پیشینگ رو میتونه برای شما بوجود بیاره ، یعنی اگه کسی شما رو معرفی کنه به گوگل یا یاهو امکان داره اونها ایمیل هاتون رو اسپم کنند ولی با استفاده از تنظیمات smtp خود هاستتون شما می تونید با خیال راحت به ارسال ایمیل بپردازید.
نکته دوم اینه که شما بهتره برای ارسال ایمیل هاتون از آدرس ایمیل info@yourname.com استفاده کنید که جنبه رسمی تری داره و میتونید با ساخت یک اکانت در کنترل پنل هاستتون (البته در بعضی هاست ها محدودیت تعداد وجود داره و در بعضی دیگه اصلاً این امکان وجود نداره ، اینا همش به هاستی که تهیه می کنید مربوطه) اون رو توی تنظیمات به عنوان آدرس ایمیل سایت قرار بدید ، همچنین پیشنهاد بعدی اینه که تمامی ایمیل های فرستاده شده به همون آدرس info تون رو توی کنترل پنل هاست forward کنید به ایمیل شخصیتون یا ایمیلی که برای سایتتون توی گوگل یا یاهو ساختید.
zahramehdi

    عضو جدید

  • عضو انجمن
  • 0 محبوبیت
  • 2 ارسال

ارسالی 29 May 2012 - 03:55 PM

سلام من اصلا نمیتونم ایمیلی ارسال کنم از پورت sslوشماره پورت 465استفاده میکنم و ایمیلمم گوگل میباشد میشه راهنمایی کنید ؟
p3ym4n

    عضو انجمن

  • عضو انجمن
  • ستارهستاره
  • 4 محبوبیت
  • 96 ارسال

ارسالی 31 May 2012 - 11:33 AM

سلام من اصلا نمیتونم ایمیلی ارسال کنم از پورت sslوشماره پورت 465استفاده میکنم و ایمیلمم گوگل میباشد میشه راهنمایی کنید ؟

شما اگه فقط آخرین پست رو میخوندی مشکلت حل میشد ،

در مورد این قسمت باید بگم که تنظیمات گوگل کار نمی کنه و این هم فک کنم بخاطر
خود گوگل هست نه تنها اینجا بلکه تو دیگری فروم های خارجی پرستا سر این
موضوع بحث بوده و به نتیجه ای نرسیدن ، این تنظیماتی که تو پست اول اومده
توسط خود گوگل پخش شده و درست هم هست ولی کار نمی کنه!


zahramehdi

    عضو جدید

  • عضو انجمن
  • 0 محبوبیت
  • 2 ارسال

ارسالی 05 June 2012 - 04:35 PM

سلام
من از ایمیل hotmailدارم استفاده میکنم هم نمیشه ؟
p3ym4n

    عضو انجمن

  • عضو انجمن
  • ستارهستاره
  • 4 محبوبیت
  • 96 ارسال

ارسالی 05 June 2012 - 05:11 PM

من از ایمیل hotmailدارم استفاده میکنم هم نمیشه ؟

شما به پست اول همین تریت مراجعه کن و طبق اونها تنظیماتت رو انجام بده اگه نشد اینجا اعلام کن ، در ضمن اگه هاستت سرویس stmp داره از اون استفاده کن که به نظرم معتبر تره!
kbdk

    عضو تازه وارد

  • عضو انجمن
  • ستاره
  • 3 محبوبیت
  • 17 ارسال

ارسالی 03 July 2012 - 05:06 AM

سلام دوستان عزیز

( آموزش روش تنظیم ایمیل خود هاست برای پرستا شاپ که خیلی بهتر و باکلاستره !!! )

من امشب تصمیم گرفتم یکی از سایت هامون رو هم با پرستا شاپ بر پا کنم .
چند ساعت پیش نسخه اخر رو نصب کردم و داشتم تنظیمات اینارو ست می کردم . که یکم پیش متوجه شدم پرستا اصلا برای مشتری و نه برای مدیر ایمیل ارسال نمی کنه . البته هاست من مشکل ارسال ایمیل با چند نوع CMS ای که روش نصب کردم تا الان نداشته .و موقع نصب هم ایمیل تست رو درست ارسال کرد !!!!! :huh:
حالا بگزریم

هاست من که روش تست کردم لینوکس و با پنل سی پنل هست :

نحوه انجام :

1- ابتدا وارد سی پنل هاست خود شوید و روی Email Accounts کلیک کنید

2- و در اینجا یک ایمیل ایجاد کنید
:idea: ( مثلا ) این ایمیل و پسورد
info@yourdomain.com
و پسورد
12345678

3- خب بعد از اینکه روی Create Account کلیک کردید و ایمیل مورد نظر ایجاد شد . در تب پایین نمایش داده می شه
حالا شما باید روی گزینه Mail Client Configuration که داخل گزینه more هست کلیک کنید

4- در قسمت پایین که نوشته
Manual Settings

همه مشخصات مورد نیاز شما لیست شده و نیاز نیست با میزبانتون هم تماس بگیرید .
سعی کنید از پورت SSL استفاده کنید - و احتمالا پورت هم مثل ما برای شما هم 465 خواهد بود.جلوی Outgoing Mail Server نوشته .

5- حالا به قسمت مدیریت پرستا شاپ > تنظیمات > ایمیل برید و گزینه
پارامترهای SMTP من را مقدار دهی کن. فقط برای کاربران حرفه ای
را انتخاب کنید - البته کاربر حرفه ای نمی خواد همه می تونن انجام بدن ولی یکم دقت کنید خواهشن . :shy:

و بعد فیلد ها رو به ترتیب تکمیل کنید

دامنه ایمیل
رو خالی بگذارید این مهم نیست


سرویس دهنده SMTP
از رو این قسمت قرمز که برای شما هر چی که نوشته کپی و پست کنید (همون جایی هست که بالا عرض کردم) (Manual Settings)

Outgoing Mail Server: (SSL) server15.yourdomain.com (server requires authentication) port 465


کاربر SMTP
اینم با توجه به ایمیلی که ساختید وارد کنید - در مثالی که ما ایجاد کردیم می شه این
info@yourdomain.com

کلمه عبور SMTP
برای این مورد هم که همون رمزی که موقع ساخت اکانت ایمیل داده رو وارد کنید - که در مثالی که ما ایجاد کردیم می شه این
12345678

رمزگذاری
SSL

درگاه
465

و بعد روی ذخیره کلیک کنید.کار تمام است و برای تست در قسمتی که نوشته
بررسی تنظیمات ایمیل شما
مثلا یه ایمیل یاهو خودتونو وارد کنید و روی ارسال یک ایمیل آزمایشی کلیک کنید
باید ظرف یکی دو ثانیه این ایمیل رو دریافت کنید که داخلش نوشته شده:
این یک پیام آزمایشی است، سرور شما اکنون آماده ارسال ایمیل است

:)

خب اگه ارسال نشده :dodgy: چک کنید ببینید تنظیمات رو صحیح وارد کردید یا خیر ؟

برای من که جواب داد :rolleyes:

با تشکر
موفق باشید


 
لطفا عزیزانی که مشکل ارسال ایمیل داشتند تست کنن و نتیجه رو اگه مشکلی از
نظر مدیران عزیز نداره اینجا اعلام کنن تا برای بقیه هم یه راهی پیدا شه

من رو سرور المان و امریکا تست کردم اوکی بود و پورت SLL هر دو 465 بود .
new_sra

    مدیر اخراج شده

  • مسدود شده
  • ستارهستارهستارهستارهستاره
  • 6 محبوبیت
  • 1535 ارسال

ارسالی 03 July 2012 - 09:12 AM

با سپاس از حوصله اي كه به خرج دادي و نوشتي ولي اگه كمي بيشتر كنكاش مي كردي در مديريت پرستا دريافت مي كردي كه تنها كافي بود ماژول
تصویر باخبرسازی توسط ایمیل
رو نصب مي كردي و احتياج به هيچ يك از كارهاي بالا نبود :D
kbdk

    عضو تازه وارد

  • عضو انجمن
  • ستاره
  • 3 محبوبیت
  • 17 ارسال

ارسالی 03 July 2012 - 02:31 PM

درود

درسته ولی فکر کنم برای اونایی که در قسمت ارتباط با ما و ارسال مشخصات کالای مجازی و ... بازم با اون مشکل داشته باشن - لازم باشه . ضرر

نداره :D

چون تو فروم دیدم کاربران چند جا گفته بودند بعد استفاده از

تصویر باخبرسازی توسط ایمیل v2.2 توسط PrestaShop

باز هم همون مشکل رو دارند .

البته الان خودمم تست کردم برای مدیر ایمیل ارسال کرد ولی پاسخ قسمت ارتباط با ما رو برای مشتری ارسال نمی کنه ! :(


ارادتمند
new_sra

    مدیر اخراج شده

  • مسدود شده
  • ستارهستارهستارهستارهستاره
  • 6 محبوبیت
  • 1535 ارسال

ارسالی 03 July 2012 - 04:00 PM

باقي مشكلات مربوط به عدم سازگاري هاستشونه و در مورد ارتباط با ما هم بايد خوب بريد بخش كارمندان و تماس و اونجا تنظيم كنيد
دانوش

    مدیر پروژه

  • مدیر کل
  • 572 محبوبیت
  • 5188 ارسال

ارسالی 04 July 2012 - 11:47 AM

اگر تابع ایمیل در هاست غیرفعال باشه تنظیم smtp ضروری هست در غیر این صورت هیچ ایمیلی برای مدیر و مشتریان صادر نمیشه!
تنظیمات smtp در هاست های مختلف متفاوته و این طور نیست که همیشه 465 شماره پورت باشه و رمزگذاری داشته باشه
ممکنه هیچ رمزگذاری نداشته باشه و پورت هم 25 باشه.
بهترین راه اینه که از طریق پشتیبانی هاست از این تنظیمات مطلع بشید
یک نکته مهم دیگه هم اینه که همیشه ارسال ایمیل تست جواب نمیده و ممکنه این ایمیل ارسال نشه حتی اگه تنظیمات درست باشه مخصوصا وقتی از gmail استفاده کنید!
همیشه تنظیمات رو که انجام دادید از طریق فرم تماس با ما امتحان کنید.
armanaria111

    عضو جدید

  • عضو انجمن
  • 0 محبوبیت
  • 8 ارسال

ارسالی 09 March 2013 - 04:20 PM

خطا: لطفا تنظیمات را بررسی کنید
The SMTP connection failed to start [ssl://smtp.gmail.com:465]: fsockopen returned Error Number 110 and Error String 'Connection timed out
این خطا برای چیه

0 کاربر در حال خواندن این موضوع است

0 کاربر، 0 مهمان و 0 عضو مخفی